Barbanet_UruguayRegions 1.0.0

Agregando más opciones/valores que hacen falta por estas latitudes, luego de haber hecho el de Argentina, toca replicar el de Uruguay (con la lista curada por Alejandro Marroni).

El módulo está diponible, como de costumbre, tanto en GitHub como en Packagist.

Para instalarlo, los pasos son:

composer require barbanet/magento2-uruguayregions

Luego lo habilitamos en Magento.

bin/magento module:enable Barbanet_UruguayRegions

Actualizamos la base de datos:

bin/magento setup:upgrade

Y finalmente, limpiamos cache.

bin/magento cache:clean

Ahora si, nuestra tienda tiene los departamentos de Uruguay.

Tweet about this on TwitterShare on Google+Email this to someoneShare on FacebookShare on LinkedIn

4 pensamientos en “Barbanet_UruguayRegions 1.0.0

  1. Alberto Farías

    Damián buenas tardes!
    Excelente blog.
    Puedes por favor iluminarme para hallar el requerimiento: magento/module-directory 100.*
    Composer no es capaz de resolverlo y yo tampoco…

    Gracias desde ya!

  2. Damián Autor

    Alberto, ¿qué versión de Magento estás utilizando?. Lo he probado con 2.0.x y 2.1.x y no ha habido problemas.

  3. Alberto Farías

    Damián, gracias por la respuesta.
    Utilizo la versión 2.1.3.
    Hoy al intentar instalar para enviarte el resultado, se presenta un problema diferente al original.
    Adjunto resultado desde consola:
    Using version ^1.0 for barbanet/magento2-uruguayregions ./composer.json has been updated
    Loading composer repositories with package informaUpdating dependencies (including require-dev) Your requirements could not be resolved to an installable set of packages.

    Problem 1
    – The requested package magento/product-community-edition (locked at 2.1.3, required as 2.0.6) is satisfiable by magento/product-community-edition[2.1.3] but these conflict with your requirements or minimum-stability.
    Problem 2
    – Can only install one of: magento/framework[100.0.8, 100.1.3].
    – Can only install one of: magento/framework[100.1.3, 100.0.8].
    – Can only install one of: magento/framework[100.1.3, 100.0.8].
    – magento/product-community-edition 2.0.6 requires magento/framework 100.0.8 -> satisfiable by magento/framework[100.0.8].
    – Installation request for magento/product-community-edition 2.0.6 -> satisfiable by magento/product-community-edition[2.0.6].
    – Installation request for magento/framework (locked at 100.1.3) -> satisfiable by magento/framework[100.1.3].

    Installation failed, reverting ./composer.json to its original content.

    Cordiales saludos.

  4. Alberto Farías

    Tema solucionado!
    Sólo fue necesario forzar un update a la misma versión con composer require magento/product-community-edition 2.1.3 –no-update

    Finalizado todo el proceso de update, comenzar la instalación del módulo nuevamente.
    Saludos.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *