Archivo de la categoría: Ubuntu

Cambiar directorio de base de datos de Mysql en Ubuntu

Pequeña hoja de ruta para cuando tengamos que reubicar nuestras bases de datos en un directorio o partición o disco diferente:

1) Detenemos el servicio Mysql

sudo service mysql stop

2) Creamos la nueva ubicación

sudo cp -R /var/lib/mysql /nueva/ubicacion/de/mysql

Y borramos los archivos ib_logfile

sudo rm /nueva/ubicacion/de/mysql/ib_logfile*

3) Asignamos propietario a los nuevos archivos

sudo chown -R mysql:mysql /nueva/ubicacion/de/mysql

4) Editamos la configuración de Mysql

Aquí un pequeño detalle, no vamos a cambiar el archivo /etc/mysql/my.cnf, sino que vamos a crear un nuevo archivo dentro de /etc/mysql/conf.d, por ejemplo: mi_configuracion.cnf

Sigue leyendo

Syngery en Ubuntu 14.04

Configuración Synergy

Luego de haber actualizado una de las computadoras de Ubuntu 12.04 a 14.04, me encontré con el segundo y (por el momento) último problema.

Desde hace ya 7 años uso de forma permanente Synegry para trabajar. Es definitivamente la solución más estable que he probado.

Hasta la versión 12.04 de la distro, la versión de repositorio de Synergy era la 1.3.8; mientras que en Ubuntu 14.04, es la 1.4.12.

La diferencia de versiones hace que si la versión servidor es 1.3.8 y el cliente 1.4.12, éste último no logre conectarse.

Por suerte, a la 12.04 (la cual uso como servidor Synegry) aún le quedan algunos trucos. Si ejecutamos:

aptitude versions synergy

Sigue leyendo

“no talloc stackframe” en Ubuntu 14.04

Hace unos días me tocó, al fin, actualizar un equipo de Ubuntu 12.04 a 14.04.

La actualización funcionó correctamente, sin problemas; aunque si me encontré, por el momento, con algunos detalles que requirieron atención.

Ya sea ejecutando un comando con sudo o como root directamente, me aparecía el siguiente mensaje.

no talloc stackframe at ../source3/param/loadparm.c:4864, leaking memory

Esto es un bug que ya tiene unos meses y si bien aún no ha sido solucionado de forma efectiva, en el comentario #14 tenemos la solución temporal.

Lo primero será ejecutar:

pam-auth-update

Aquí veremos las opciones de configuración y vamos a deshabilitar “SMB password synchronization”.

Configuración PAM en Ubuntu

Luego confirmamos y a partir de ese momento ya dejaríamos de padecer el problema.

El teclado numérico no funciona en Ubuntu

En una de las últimas actualizaciones de la distro me pasó que el teclado numérico ya no funcionaba.

Lo primero que pensé fue que alguna de las actualizaciones requería algún reinicio (reconozco que no le presté gran atención a la lista de paquetes) y que ésto estaba generando algún tipo de incompatibilidad o conflicto entre paquetes.

Luego de haber reiniciado, la molestia se convirtió en problema. Buscando un poco encontré el bug sobre el no funcionamiento del teclado numérico en Ubuntu.

Al parecer se viene arrastrando el tema desde hace varias ediciones, aunque la solución es realmente sencilla.

Lo primero, es abrir “Tecnologías de asistencia”.

Ahora vamos a las opciones de “Accesibilidad del teclado”.

Sigue leyendo

Error de Eclipse en Ubuntu 10.04 con PhpEclipse

La versión de repositorios de Eclipse para Ubuntu nunca ha funcionado perfectamente, siempre hay que ajustar algo.

En Ubuntu Lucid Lynx no vamos a encontrarnos con la excepción.

En mi caso, el error se presentó al querer instalar PhpEclipse. Durante el proceso, recibí un mensaje de error.

Ahora bien, a diferencia de otras veces, me puse a buscar (no puede ser que siempre haya problemas con ésta ide).

Después de leer muchísimos threads y hacer unas cuantas pruebas en más de un desktop, encontré que la forma para solucionarlo era agregando paquetes de Eclipse que por defecto no se instalan.

Para solucionarlo, vamos a buscar si los paquetes eclipse-pde eclipse-jdt eclipse-rcp están instalados.

root@linux:~# aptitude search eclipse-pde eclipse-jdt eclipse-rcp
p   eclipse-jdt                                                            - Eclipse Java Development Tools (JDT)
p   eclipse-pde                                                            - Eclipse Plug-in Development Environment (PDE)
i A eclipse-rcp                                                            - Eclipse Rich Client Platform (RCP)

Sigue leyendo