Magento 1.9.2.4 (SUPEE-7405 V1.1)

Magento SUPEE-7405 v1.1

En las últimas horas de ayer se publicó la versión 1.9.2.4 de Magento, la cual incluye el parche (paquete de parches) SUPEE-7405 v1.1.

El detalle de cada parche provisto está documentado en la página de la nueva versión. Esos parches son:

  • SUPEE-7978: soluciona el problema de cantidades en el carrito cuando se mergeaba el mismo item.
  • SUPEE-7822: corrige problema de la API SOAP que podía generar un error 500.
  • SUPEE-7882: con la aplicación de este parche se dejaba PHP 5.3 como versión mínima y se requería de la versión 5.4. Esto ha sido revertido y nuevamente PHP 5.3 es la versión mínima con la cual corre Magento.
  • Corrección al problema del uploader de imágenes (problema que tantas preguntas ha generado en los foros)

En cuanto a los archivos modificados, todos pertenecen al backend (ningún archivo del frontend ha cambiado).

Los archivos modificados en la versión 1.9.2.4 son:

app/code/core/Mage/Adminhtml/Helper/Sales.php
app/code/core/Mage/Core/Model/Config.php
app/code/core/Mage/Sales/Model/Quote/Item.php
app/locale/en_US/Mage_Core.csv
app/locale/en_US/Mage_ImportExport.csv
app/locale/en_US/Mage_Page.csv
app/locale/en_US/Mage_Usa.csv
dev/tests/functional/tests/app/Mage/Payment/Test/Repository/Cc.xml
lib/Varien/File/Uploader.php
lib/Varien/Http/Adapter/Curl.php

Para que funcione el parche, es condición instalar primero la versión 1.0 de SUPEE-7405. Luego si se podrá instalar la versión 1.1.

Si ya están trabajando con Magento 1.9.2.3, esto no es necesario ya que la propia versión lo incluye, allí directamente aplicaríamos la versión 1.1 del parche.

Al aplicar el parche sobre una versión 1.9.2.3, los archivos que cambian son:

app/code/core/Mage/Adminhtml/Helper/Sales.php
app/code/core/Mage/Core/Model/Config.php
app/code/core/Mage/Sales/Model/Quote/Item.php
lib/Varien/File/Uploader.php
Tweet about this on TwitterShare on Google+Email this to someoneShare on FacebookShare on LinkedIn